Register    Login    Forum    Search    FAQ

Board index » Software » Linux




Post new topic Reply to topic  [ 15 posts ]  Go to page Previous  1, 2
Author Message
 Post Posted: Fri Nov 10, 2017 9:15 am 
Offline

Joined: Thu Feb 09, 2017 4:58 am
Posts: 92
Ok, please let me know any other questions.

Thanks
chad

_________________
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China


Top 
 Profile  
Reply with quote  
 Post Posted: Fri Nov 10, 2017 9:21 am 
Offline

Joined: Tue Feb 16, 2016 9:51 pm
Posts: 10
Hello Chad,

an update:
tested again, now on my ASTRO machine.
Changed there also the usbfs memory and run firecapture again. There is some improvement but still lots of errors, even without recording to disc. In 8 bit mode seems to be better (even when recording, only a few errors)
In 16 bit when recording, camera speeds jumps between 4fps and 29 fps with lots of errors 11.

Then I rebooted that same system in W10. Started firecapture with camera in the same usb port. Started in 16 bit mode ans started recording. Camera speed stays steady around 29 fps. Even when starting browser and browse internet or do something else. (On Linux, when I touch any other ap, I can see errors coming when reading the camera)

Very strange, starting to loose my confidence in Linux ...

The processor on that machine (AMD Ryzen3-1200) is not the fastest, but cam works in W10 like a charm. (And even on my I7-4790K it is not completely without those errors) Do you have any experience how it works on Mac? (Don't have a Mac to experiment :( )

Regards,

Paul


Top 
 Profile  
Reply with quote  
 Post Posted: Mon Nov 13, 2017 1:51 am 
Offline

Joined: Thu Feb 09, 2017 4:58 am
Posts: 92
Hi Paul,
Have you checked the value of usbfs_memory_mb? Make sure your modifications are successful.
In addition, try to increase the value to no more than 1024 to see if there is any improvement, like change it to 512.

About the browser, other users have responded, but we're not sure why.

Linux is very flexible, so it's inevitable to have some strange problems. Sometimes, solving these problems can be a great pleasure.

On a Mac, it's better than Linux, but there are people who have problems.

Thanks
chad

_________________
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China


Top 
 Profile  
Reply with quote  
 Post Posted: Mon Nov 13, 2017 6:48 am 
Offline

Joined: Tue Feb 16, 2016 9:51 pm
Posts: 10
Hi Chad,

Yes I checked, but for some reason when setting it up from grub it will not go over 200. Tried setting manually, but no idea if that really set the value higher. (You never know in Linux). You are right it can be a battle to make things work.

Looks like I will have to use my W10 license for the astro machine for the moment (had other plans for that) and do some more testing on my main machine.

Best regards,

Paul


Top 
 Profile  
Reply with quote  
 Post Posted: Mon Nov 13, 2017 7:38 am 
Offline

Joined: Thu Feb 09, 2017 4:58 am
Posts: 92
Hi paul,
Use this command:
"echo 200 > /sys/module/usbcore/parameters/usbfs_memory_mb" to write it.
It failed, add sudo before it.
then using "cat /sys/module/usbcore/parameters/usbfs_memory_mb" to check it.
Generally speaking, it supports to set from 0 to 2048.
Thanks
chad

_________________
ZWO Driver Engineer
Location:lon=120.6 lat=31.3
SuZhou China


Top 
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 15 posts ]  Go to page Previous  1, 2

Board index » Software » Linux


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: