Register    Login    Forum    Search    FAQ

Board index » Products » Cameras




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post Posted: Mon Nov 27, 2017 2:26 am 
Offline

Joined: Mon Nov 27, 2017 2:15 am
Posts: 6
Does anyone know the Bayer Matrix for ZWO ASI224MC?

Is it R-G-G-B?

I am getting terrible colors when I do a de-bayering of the 16-bit FITS file, using Nebulosity (latest version, 4.17).

I've tried changing the diagonal terms of the color balance matrix, but nothing works

There are two attachments:
The default is using R-G-B = 1.0 1.0 1.0, and the nebula looks yellow
I tried this, R-G-B = 0.6 0.8 1.6, and the nebula is starting to look normal at the expense of all the stars and background being much too blue.

Any help is appreciated.

Steve

P.S. Sorry if this issue has been addressed, but I did a search on the forum and surprisingly, nothing came up on this topic.


Attachments:
Nebulosity_with_RGB_0p6-0p8-1p6.JPG
Nebulosity_with_RGB_0p6-0p8-1p6.JPG [ 49.24 KiB | Viewed 174 times ]
Nebulosity_with_RGB_1-1-1.JPG
Nebulosity_with_RGB_1-1-1.JPG [ 50.91 KiB | Viewed 174 times ]
Top 
 Profile  
Reply with quote  
 Post Posted: Mon Nov 27, 2017 8:43 am 
Offline
User avatar

Joined: Thu Feb 21, 2013 2:51 am
Posts: 2332
it's RGGB, but different app call it different
I think the yellow one is correct
you need to adjust the white balance to make the color better

_________________
ZWO Founder
Location:lon=120.6 lat=31.3
SuZhou China


Top 
 Profile  
Reply with quote  
 Post Posted: Mon Nov 27, 2017 8:34 pm 
Offline

Joined: Mon Nov 27, 2017 2:15 am
Posts: 6
Sam wrote:
it's RGGB, but different app call it different
I think the yellow one is correct
you need to adjust the white balance to make the color better


This is an image of a blue cable on a brown desk. When I debayer it with RGB , the cable is green.
When I use CMYG, it gets much closer.
But I cannot use CMYG for the nebula, as it creates an odd aritfact.


Attachments:
Nebulosity_with_CMYG_1-1-1.JPG
Nebulosity_with_CMYG_1-1-1.JPG [ 25.12 KiB | Viewed 149 times ]
blue-cable-on-brown-desk_using_CMYG.jpg
blue-cable-on-brown-desk_using_CMYG.jpg [ 825.63 KiB | Viewed 149 times ]
blue-cable-on-brown-desk.jpg
blue-cable-on-brown-desk.jpg [ 103.08 KiB | Viewed 149 times ]
Top 
 Profile  
Reply with quote  
 Post Posted: Mon Nov 27, 2017 8:46 pm 
Offline

Joined: Mon Nov 27, 2017 2:15 am
Posts: 6
bellavia wrote:
Sam wrote:
it's RGGB, but different app call it different
I think the yellow one is correct
you need to adjust the white balance to make the color better


This is an image of a blue cable on a brown desk. When I debayer it with RGB , the cable is green.
When I use CMYG, it gets much closer.
But I cannot use CMYG for the nebula, as it creates an odd aritfact.



This is interesting: I opened the same file in APT's previewer.

The cable is still green, but the desk is closer to brown (yellow?)


Attachments:
blue-cable-on-brown-desk_APT.jpg
blue-cable-on-brown-desk_APT.jpg [ 183.79 KiB | Viewed 149 times ]
Top 
 Profile  
Reply with quote  
 Post Posted: Wed Nov 29, 2017 6:27 am 
Offline
User avatar

Joined: Thu Feb 21, 2013 2:51 am
Posts: 2332
this is because there is no IR-CUT filter

you can add one IR-CUT filter so the final image is not so red

_________________
ZWO Founder
Location:lon=120.6 lat=31.3
SuZhou China


Top 
 Profile  
Reply with quote  
 Post Posted: Wed Nov 29, 2017 1:55 pm 
Offline

Joined: Mon Nov 27, 2017 2:15 am
Posts: 6
Sam wrote:
this is because there is no IR-CUT filter

you can add one IR-CUT filter so the final image is not so red


But the image is NOT too RED. it is too GREEN, which is the opposite of RED.

I think there is something wrong with the method the FITS header is being written OR the matrix is NOT R-G-G-B.

I was using this camera as a test to see if I would purchase a lager chip, cooled ZWO color camera.

But after this experience, I will not. It is not working out at all, and there is very little help or technical support of these products.


Top 
 Profile  
Reply with quote  
 Post Posted: Thu Nov 30, 2017 6:41 pm 
Offline

Joined: Mon Nov 27, 2017 2:15 am
Posts: 6
bellavia wrote:
Sam wrote:
this is because there is no IR-CUT filter

you can add one IR-CUT filter so the final image is not so red


But the image is NOT too RED. it is too GREEN, which is the opposite of RED.

I think there is something wrong with the method the FITS header is being written OR the matrix is NOT R-G-G-B.

I was using this camera as a test to see if I would purchase a lager chip, cooled ZWO color camera.

But after this experience, I will not. It is not working out at all, and there is very little help or technical support of these products.


Hi again,
It took much effort, but I resolved the issue.
You need to apply an offset, as the software does not "know" which pixel to start with for the R-G-G-B mosaic.
For Nebulosity, the offset is 1,1 for X,Y
Then, after that, you can tweak further. This is not final (as I am still waiting for my photo color card to arrive), but does present fairly good colors. I will post again if I improve upon this but for now, the color balance matrix should be as follows:

0.87 0.10 0.00
0.10 0.89 0.00
0.00 0.25 1.30

These are the rows and columns for R-G-B
the columns are the input, and the rows are output
For example, row 1 above is applying 87% of the red to the red channel, 10% of green to the red channel and 0% of blue to the red channel. (This does not have to add up to 100%, nor does the determinant of this matrix need to be 1.0)

Attached is the summary of what I have done so far.

As I said, if I get it better, I'll let you know, but this is a good place to start


Attachments:
ZWO ASI224MC Demosaic-ing in Nebulosity.png
ZWO ASI224MC Demosaic-ing in Nebulosity.png [ 580.85 KiB | Viewed 119 times ]
Top 
 Profile  
Reply with quote  
 Post Posted: Fri Dec 01, 2017 4:00 am 
Offline
User avatar

Joined: Thu Feb 21, 2013 2:51 am
Posts: 2332
white balance is always need to adjust
and different software use different way

that's good news there is some improvement

_________________
ZWO Founder
Location:lon=120.6 lat=31.3
SuZhou China


Top 
 Profile  
Reply with quote  
 Post Posted: Tue Dec 05, 2017 1:26 am 
Offline

Joined: Mon Nov 27, 2017 2:15 am
Posts: 6
Sam wrote:
white balance is always need to adjust
and different software use different way

that's good news there is some improvement


I finally got my color card, and the latest settings to get better colors are extremely simple (actually embarrassing, considering what I had in my last post, as it is just the diagonal terms, and nice round numbers).
This seems to work well enough to call it a day:

Matrix offset x,y: 1,1

Color Control:

R G B
R 0.80 0.00 0.00
G 0.00 0.80 0.00
B 0.00 0.00 1.25


Attachments:
ZWO_ASI224MC_color_Card_color_balance_15-resize.jpg
ZWO_ASI224MC_color_Card_color_balance_15-resize.jpg [ 442.63 KiB | Viewed 64 times ]
color_control_15.jpg
color_control_15.jpg [ 34.41 KiB | Viewed 64 times ]
Top 
 Profile  
Reply with quote  
 Post Posted: Thu Dec 07, 2017 2:15 am 
Offline
User avatar

Joined: Thu Feb 21, 2013 2:51 am
Posts: 2332
thanks for sharing

_________________
ZWO Founder
Location:lon=120.6 lat=31.3
SuZhou China


Top 
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 10 posts ] 

Board index » Products » Cameras


Who is online

Users browsing this forum: No registered users and 3 guests

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: