Register    Login    Forum    Search    FAQ

Board index » Products » Accessories




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Dew Heater failure
 Post Posted: Fri Jun 30, 2017 6:41 pm 
Offline

Joined: Sat Jun 24, 2017 2:03 pm
Posts: 9
Attachment:
torn heater.jpg
torn heater.jpg [ 374.78 KiB | Viewed 379 times ]
The dew heater I have, has structurally failed after a couple of weeks of very light usage. The plastic holding the two leads that connect with the heating elements, has torn and the elements are broken. This is light usage and I have made an effort to treat it gently. Just picking up the camera with the heater attached, causes a twisting of the plastic containing the heating elements.

This is an extremely weak point in the design, the only solution provided with the heater is a couple of plastic ties to hold the heater lead against the body of the camera. These interfere with the use of the plastic camera holder. This is a major design flaw and I have to rate it "F".

Right now I need a replacement because of very humid local weather. I will try to order one but ZWO needs to find something better! :x :x :x


Top 
 Profile  
Reply with quote  
 Post subject: Re: Dew Heater failure
 Post Posted: Sat Jul 01, 2017 11:25 am 
Offline

Joined: Sat Jun 24, 2017 2:03 pm
Posts: 9
re my dew heater failure:

In fairness, if the camera is kept mounted face against the filter wheel, as it's normally used, there is a a lot less twisting and flex of the vulnerable plastic tab. I now always keep it this way, and tape the wiring to the side of the camera under a little bit of tension. Not much else one can do.

Handle with care, people! :roll: :roll:


Top 
 Profile  
Reply with quote  
 Post subject: Re: Dew Heater failure
 Post Posted: Tue Jul 04, 2017 6:18 am 
Offline
User avatar

Joined: Thu Feb 21, 2013 2:51 am
Posts: 2127
sorry for this issue, but are you show our newest 1600 still need this heater?

_________________
ZWO Founder
Location:lon=120.6 lat=31.3
SuZhou China


Top 
 Profile  
Reply with quote  
 Post subject: Re: Dew Heater failure
 Post Posted: Tue Jul 04, 2017 1:47 pm 
Offline

Joined: Sat Jun 24, 2017 2:03 pm
Posts: 9
Hello, Sam.

I can't yet say the 1600 needs the dew heater for sure. I was having a problem with a bright fog or flare in my images, that turned out to be from a light leak in my Manual Filter Wheel (the opening to access the filter wheel let a lot of light in). I plugged this by wrapping a heating tape around the circumference of the MFW. Easy to move when I need to change the filter. This may also serve as enough of a heater to be sure there's never any need for the ZWO made heater.

I did read from some people who say theu had dew or even frost without the ZWO heater.

So much experimenting to do! I love this camera, fear not. :D

Thanks, Sam!


Top 
 Profile  
Reply with quote  
 Post subject: Re: Dew Heater failure
 Post Posted: Thu Jul 06, 2017 7:22 am 
Offline
User avatar

Joined: Thu Feb 21, 2013 2:51 am
Posts: 2127
the old version may need it, but new version may don't need
you can try
thanks for your encourage
we can do better in the future

_________________
ZWO Founder
Location:lon=120.6 lat=31.3
SuZhou China


Top 
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
 
Post new topic Reply to topic  [ 5 posts ] 

Board index » Products » Accessories


Who is online

Users browsing this forum: No registered users and 1 guest

 
 

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: